<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml">

<head profile="http://gmpg.org/xfn/11">

<link rel="shortcut icon" href="http://www.dbms2.com/wp-content/themes/monash/favicon.ico" />

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

<meta name="distribution" content="global" />

<meta name="robots" content="follow, all" />

<meta name="robots" content="noodp" />

<meta name="language" content="en, sv" />



<title>Brittleness, Murphy&#039;s Law, and single-impetus failures | DBMS 2 : DataBase Management System Services</title>

<meta name="generator" content="WordPress 4.9.6" />

<!-- leave this for stats please -->





<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="http://www.dbms2.com/feed/" />

<link rel="alternate" type="text/xml" title="RSS .92" href="http://www.dbms2.com/feed/rss/" />

<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="http://www.dbms2.com/feed/atom/" />

<link rel="pingback" href="http://www.dbms2.com/xmlrpc.php" />

 


<!-- All in One SEO Pack 2.6.1 by Michael Torbert of Semper Fi Web Design[553,669] -->
<meta name="description"  content="In my initial post on brittleness I suggested that a typical process is: Build something brittle. Strengthen it over time. In many engineering scenarios, a" />

<meta name="keywords"  content="analytic technologies,text" />

<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="DBMS 2 : DataBase Management System Services &raquo; Brittleness, Murphy&#8217;s Law, and single-impetus failures Comments Feed" href="http://www.dbms2.com/2018/06/20/brittleness-murphys-law-and-single-impetus-failures/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.0.3 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<!-- Note: MonsterInsights is not currently configured on this site. The site owner needs to authenticate with Google Analytics in the MonsterInsights settings panel. -->
<!-- No UA code set -->
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.dbms2.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.6"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='https://api.w.org/' href='http://www.dbms2.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.dbms2.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.dbms2.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Brittleness and incremental improvement' href='http://www.dbms2.com/2018/06/20/brittleness-and-incremental-improvement/' />
<link rel='next' title='New legal limits on surveillance in the US' href='http://www.dbms2.com/2018/06/25/new-legal-limits-on-surveillance-in-the-us/' />
<meta name="generator" content="WordPress 4.9.6" />
<link rel="canonical" href="http://www.dbms2.com/2018/06/20/brittleness-murphys-law-and-single-impetus-failures/" />
<link rel='shortlink' href='http://www.dbms2.com/?p=10367' />
<link rel="alternate" type="application/json+oembed" href="http://www.dbms2.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.dbms2.com%2F2018%2F06%2F20%2Fbrittleness-murphys-law-and-single-impetus-failures%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.dbms2.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.dbms2.com%2F2018%2F06%2F20%2Fbrittleness-murphys-law-and-single-impetus-failures%2F&#038;format=xml" />

<!-- Bad Behavior 2.2.20 run time: 4.960 ms -->
<script type="text/javascript">
<!--
function bb2_addLoadEvent(func) {
	var oldonload = window.onload;
	if (typeof window.onload != 'function') {
		window.onload = func;
	} else {
		window.onload = function() {
			oldonload();
			func();
		}
	}
}

bb2_addLoadEvent(function() {
	for ( i=0; i < document.forms.length; i++ ) {
		if (document.forms[i].method == 'post') {
			var myElement = document.createElement('input');
			myElement.setAttribute('type', 'hidden');
			myElement.name = 'bb2_screener_';
			myElement.value = '1530772917 52.90.98.148';
			document.forms[i].appendChild(myElement);
		}
	}
});
// --></script>
		
<style type="text/css" media="screen">

<!-- @import url( http://www.dbms2.com/wp-content/themes/monash/style.css ); -->

</style>


</head>



<body>


<div id="header">

	<div class="headerleft">

		<a href="http://www.dbms2.com/"><img src="http://www.dbms2.com/wp-content/themes/monash/images/trans.gif" border=0 alt="Blog: DBMS (database management system) and analytics technology"></a>
	
		<!-- <a href="/"></a><br />

		<h2></h2> -->

	</div>

	<div class="headerright">
	
	<table align="right">
	<tr align="right">
	<td class="sponsor"><a href="http://www.monash.com"><img src="http://www.dbms2.com/wp-content/themes/monash/images/trans.gif" border=0 height="50" width="300" alt="Publisher of blog about DBMS (database management system) and analytics technology"></a></td>
	</tr>
	<tr align="right">
	<td>
		<ul>
			
			<li><a href="http://www.dbms2.com">Home</a></li>

			<li><a href="http://www.dbms2.com/database-blog/">About</a></li>
			
			<li><a href="http://www.monash.com/contact.html">Contact</a></li>

			
			<li><a href="http://www.monash.com/signup.html">Feeds</a></li>

		</ul>
	</td>
	</tr>
	</table>
	
	</div>

</div>
<div id="content">

	<div id="contentleft">
				
		<div class="time">
        June 20, 2018        </div>
		<h1>
        <a href="http://www.dbms2.com/2018/06/20/brittleness-murphys-law-and-single-impetus-failures/" rel="bookmark">Brittleness, Murphy&#8217;s Law, and single-impetus failures</a>
        </h1>		
		
		<p>In my initial post on <a href="http://www.dbms2.com/2018/06/20/brittleness-and-incremental-improvement/">brittleness</a> I suggested that a typical process is:</p>
<ul>
<li>Build something brittle.</li>
<li>Strengthen it over time.</li>
</ul>
<p>In many engineering scenarios, a fuller description could be:</p>
<ul>
<li>Design something that works in the base cases.</li>
<li>Anticipate edge cases and sources of error, and design for them too.</li>
<li>Implement the design.</li>
<li>Discover which edge cases and error sources you failed to consider.</li>
<li>Improve your product to handle them too.</li>
<li>Repeat as needed.</li>
</ul>
<p>So it&#8217;s necesseary to understand what is or isn&#8217;t likely to go wrong. Unfortunately, that need isn&#8217;t always met.  <span id="more-10367"></span></p>
<p><strong><em>Murphy&#8217;s Law and exaggerated fears</em></strong></p>
<p>We should always bear in mind Murphy&#8217;s Law, which in its simplest form states: <strong>Anything that can go wrong, will. </strong>But also remember that Murphy&#8217;s Law is a joke; and even if it were serious, <a href="http://www.strategicmessaging.com/no-market-categorization-is-ever-precise/2011/03/01/">nothing concise is ever precise</a>.</p>
<p>People who tend to over-believe in Murphy&#8217;s Law include but are hardly limited to:</p>
<ul>
<li>Bureaucrats.</li>
<li>Worried parents, especially of only children. (Later kids tend to have it easier, as their parents have more experience.)</li>
<li>Any buyer or voter you believe has been over-persuaded toward <a href="http://www.strategicmessaging.com/stoking-a-fear-and-promising-a-fix/2017/02/15/">fear, uncertainty and doubt</a>.</li>
<li>Relational bigots who view the <a href="http://www.dbms2.com/2011/07/31/the-ted-codd-guarantee/">Ted Codd guarantee</a> as an absolute requirement for data management.</li>
</ul>
<p><strong><em>Adversaries</em></strong></p>
<p>The strongest scenarios for Murphy&#8217;s Law should be adversarial ones, in which somebody is actively trying to cause problems. But even there it doesn&#8217;t always apply. For example:</p>
<ul>
<li><strong>Information security</strong> commonly fits the Murphy model. Hackers keep outwitting defenders.</li>
<li><strong>Email spam,</strong> however, does not. It&#8217;s pretty much of a solved problem; the few spam emails that still get through hardly matter.</li>
<li><strong>Web search</strong> is somewhere in between. Both sides are partially successful in the combat over <a href="http://www.texttechnologies.com/2007/01/30/adversarial-information-retrieval/">adversarial information retrieval</a>, as &#8220;good&#8221; and &#8220;bad&#8221; sites alike are both well-represented in search results.</li>
</ul>
<p><strong><em>Single-impetus failures</em></strong></p>
<p>Since bad or scary things will happen &#8212; Murphy&#8217;s Law isn&#8217;t entirely wrong &#8212; a standard design practice is to avoid <strong>single points of failure.</strong> Brittleness has a lot to do with which single points of failure have been overlooked; improvement has a lot to do with belatedly cleaning them up. In adversarial scenarios, avoiding single points of failure relates closely to <strong>defense in depth.</strong></p>
<p>Some of the nastiest surprises occur when failures have no obvious single point, yet wind up being possible from a <strong>single impetus.*</strong> This happens when multiple points or moments of failure are somehow correlated, or when they actually <strong>cascade.</strong> Examples vary widely, including:</p>
<ul>
<li>The collapse of the World Trade Center buildings.</li>
<li>An authoritarian leader who manages to destroy a whole democratic system of government.</li>
</ul>
<p>IT examples that are relatively big deals include:</p>
<ul>
<li>Security breaches in which an attacker becomes able to fully impersonate a well-credentialed user.</li>
<li>Power outages or other whole-building breakdowns that bring down all parts of a (locally) redundant cluster.</li>
<li>Software bugs that bring down all parts of a supposedly redundant system at once.</li>
<li>Analytic failures that stem from misleading data sets. (Garbage in, garbage out.)</li>
</ul>
<p><em>*I chose the phrase &#8220;single impetus&#8221; rather than &#8220;single cause&#8221; because NOTHING has a truly single cause; things only can happen when all kinds of conditions are satisfied for them to succeed. But there can indeed be an identifiable force, plan or occurrence that sets a chain of events in motion, and that&#8217;s what I&#8217;m calling the &#8220;impetus&#8221;.</em></p>
<p><strong><em>Related link</em></strong></p>
<ul>
<li>A lot of analytics turns out to be <a href="http://www.dbms2.com/2016/05/30/adversarial-analytics-and-other-topics/">adversarial</a>.</li>
</ul>
<div style="clear:both;"></div>
	 	
		<div class="postinfo">
		
		Categories: <a href="http://www.dbms2.com/category/analytics-technologies/" rel="category tag">Analytic technologies</a>, <a href="http://www.dbms2.com/category/datatype/text-search/" rel="category tag">Text</a>&nbsp;		
		<div class="call">
		<i>Subscribe to our complete <a href="http://www.monash.com/signup.html">feed</a>!</i>		</div>
		
		</div>
		
		
			
		<!--
		<rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
			xmlns:dc="http://purl.org/dc/elements/1.1/"
			xmlns:trackback="http://madskills.com/public/xml/rss/module/trackback/">
		<rdf:Description rdf:about="http://www.dbms2.com/2018/06/20/brittleness-murphys-law-and-single-impetus-failures/"
    dc:identifier="http://www.dbms2.com/2018/06/20/brittleness-murphys-law-and-single-impetus-failures/"
    dc:title="Brittleness, Murphy&#8217;s Law, and single-impetus failures"
    trackback:ping="http://www.dbms2.com/2018/06/20/brittleness-murphys-law-and-single-impetus-failures/trackback/" />
</rdf:RDF>		-->
		
		<h3>Comments</h3>
		
<!-- You can start editing here. -->

<div id="commentblock">
	<p id="comments"><b>2 Responses to &#8220;Brittleness, Murphy&#8217;s Law, and single-impetus failures&#8221;</b></p>

	<ol class="commentlist">

	
		<li class="alt" id="comment-2846002">
			aaron on
						June 20th, 2018 4:31 pm 
			<div class="commenttext">
			<p>A useful of looking at this problem is the deep misunderstanding engineers (especially software) have of priorities of consumers. Brittle designs and feature gaps are generally reflections of immature product and missed understanding of need.</p>
<p>Brittle political or software systems may reflect manipulated requirements definition.</p>
			</div>

		</li>

	
	
		<li class="" id="comment-2846069">
			<a href='http://www.monash.com' rel='external nofollow' class='url'>Curt Monash</a> on
						June 21st, 2018 8:04 am 
			<div class="commenttext">
			<p>I&#8217;d add that if there&#8217;s a missing feature, product designers usually know that. What they get wrong is how important the lack will be competitively.</p>
			</div>

		</li>

	
	
	</ol>

 


<p id="respond"><b>Leave a Reply</b></p>


<form action="http://www.dbms2.com/wp-comments-post.php" method="post" id="commentform">


<p><label for="author">Name (required)</label><br />
<input type="text" name="author" id="author" value="" size="40" tabindex="1" /></p>

<p><label for="email">Email Address(required)</label><br />
<input type="text" name="email" id="email" value="" size="40" tabindex="2" /></p>

<p><label for="url">Website</label><br />
<input type="text" name="url" id="url" value="" size="40" tabindex="3" /></p>


<!--<p><small><strong>XHTML:</strong> You can use these tags: &lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;cite&gt; &lt;code&gt; &lt;del datetime=&quot;&quot;&gt; &lt;em&gt; &lt;i&gt; &lt;q cite=&quot;&quot;&gt; &lt;s&gt; &lt;strike&gt; &lt;strong&gt; </small></p>-->

<p><textarea name="comment" id="comment" cols="50" rows="10" tabindex="4"></textarea></p>

<p><input name="submit" type="submit" id="submit" tabindex="5" value="Submit Comment" />
<input type="hidden" name="comment_post_ID" value="10367" /></p>

<p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="20d180d85e" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="104"/></p>
</form>



</div>		
					
	</div>
	
<!-- begin rss_sidebar -->

<div id="rss_sidebar">

	
    <form style='display:inline;' method="POST" action="http://www.feedblitz.com/f/f.fbz?AddNewUserDirect">
<p><a href="http://feeds.feedburner.com/MonashInformationServices?format=xml"><img src="http://www.dbms2.com/wp-content/themes/monash/images/feed-icon-blue.gif" border="0" align="top" alt="Feed: DBMS (database management system), DW (data warehousing), BI (business intelligence), and analytics technology"></a>
Subscribe to the Monash Research feed via <span style="display: inline;"><a href="http://feeds.feedburner.com/MonashInformationServices?format=xml">RSS</a></span> or email:              
                <div style="padding-left: 0px; padding-bottom: 5px">
				<input name="EMAIL" maxlength="255" type="text" size="30" style="background:#FFFFFF" value="Enter address here">
                  <input name="FEEDID" type="hidden" value="150854">
                  <input name="submit" type="submit" value="Subscribe!">
				   <!-- Following is a hidden login button -->
				   <a href="http://www.dbms2.com/wp-admin/" style='color:#000000'>Login</a>
				   </div>
                  
</form>
  		
</div>


<!-- end rss_sidebar --> <!-- box where they sign up for the feed; spans two columns -->

<!-- begin static_sidebar --> 
<div id="static_sidebar"> 

<h2>Search our blogs and white papers</h2>

	<div id="searchform">
	
	<!-- single blog search -->
	<!-- <form style='display:inline;' method="get" id="search_form" action="/">
	<input type="text" class="search_input" value="To search, type and hit enter" name="s" id="s" onfocus="if (this.value == 'To search, type and hit enter') {this.value = '';}" onblur="if (this.value == '') {this.value = 'To search, type and hit enter';}" />
	<input type="hidden" id="searchsubmit" value="Search" /></form><br /> -->
	
	<!-- Google CSE Search Box Begins -->

    <form style='display:inline' action="http://www.monash.com/searchresults.html" id="cse-search-box">
  <div>
    <input type="hidden" name="cx" value="000500165964380188956:xnk0ucisxxw" />
    <input type="hidden" name="cof" value="FORID:9" />
    <input type="hidden" name="ie" value="UTF-8" />
    <input type="text" name="q" size="18" />
    <input type="submit" name="sa" value="Search" />
  </div>
</form>
<script type="text/javascript" src="http://www.google.com/coop/cse/brand?form=cse-search-box&lang=en"></script>
	<!-- Google CSE Search Box Ends -->
	
	</div>
	<!-- promo text for all blogs goes here -->
	<h2>Monash Research blogs</h2>

<ul>
  <li> <a href="http://www.dbms2.com">DBMS 2</a> covers database management, analytics, 
    and related technologies. </li>
  <li>
    <a href="http://www.texttechnologies.com">Text Technologies</a> covers text mining, search, and social software.
  </li>
  <li>
    <a href="http://www.strategicmessaging.com">Strategic Messaging</a> analyzes marketing and messaging strategy. 
  </li>
  <li>
    <a href="http://www.monashreport.com">The Monash Report</a> examines technology and public policy issues. 
  </li>
  <li>
    <a href="http://www.softwarememories.com">Software Memories</a> recounts the history of the software industry. 
  </li>
</ul>

  <h2>User consulting </h2>
  <p>Building a short list? Refining your strategic plan? <a href="http://www.monash.com/adviseusers.html">We can help.</a>
  </p>
   
  <h2>Vendor advisory </h2>
  <p>We tell vendors what's happening -- and, more important, <a href="http://www.monash.com/advisevendors.html">what they should do about it</a>. 
  </p>

<!--

 <h2>Recent white paper</h2>
  <table width="100%" id="webcasttable">
    <tr>
      <td><p class="webcastname"><a href="http://www.monash.com/whitepapers.html">The Explosion in DBMS Choice</a></p>
        <p class="webcastlast">August, 2008</p>

  </td>
    </tr>
  </table>
  <h2>Recent webcast</h2>
  <table width="100%" id="webcasttable">
    <tr>
      <td>
 	 <p class="webcastname"><a href="http://www.devx.com/Webcasts/Article/37435">What leading database vendors don't want you to know</a></p> 
    <p class="webcastdetails">
	    Originally broadcast April 9, 2008 
		</p>
    	</td>
		</tr>
		</table>
        
-->        
        
<h2>Monash Research highlights</h2>
<table width="100%" id="webcasttable">
  <tr> 
    <td> <p class="webcastdetails">Learn about white papers, webcasts, and blog 
        highlights, by <a href="http://www.monash.com/signup.html">RSS or email</a>.</p>
      </td>
  </tr>
</table>

  </div>

<!-- end static_sidebar --> <!-- on the right, where custom promo text and code goes -->
	
<!-- begin l_sidebar -->

<div id="l_sidebar">

	<ul id="l_sidebarwidgeted">
		
	<li id="Recent">
	<h2>Recent posts</h2>
		<ul>
				<li><a href='http://www.dbms2.com/2018/06/25/new-legal-limits-on-surveillance-in-the-us/'>New legal limits on surveillance in the US</a></li>
	<li><a href='http://www.dbms2.com/2018/06/20/brittleness-murphys-law-and-single-impetus-failures/'>Brittleness, Murphy&#8217;s Law, and single-impetus failures</a></li>
	<li><a href='http://www.dbms2.com/2018/06/20/brittleness-and-incremental-improvement/'>Brittleness and incremental improvement</a></li>
	<li><a href='http://www.dbms2.com/2018/05/20/technology-implications-of-political-trends/'>Technology implications of political trends</a></li>
	<li><a href='http://www.dbms2.com/2018/05/20/some-stuff-thats-always-on-my-mind/'>Some stuff that&#8217;s always on my mind</a></li>
		</ul>
	</li>
	
	<li id="Categories">
	<h2>Categories</h2>
		<ul>
				<li class="cat-item cat-item-2"><a href="http://www.dbms2.com/category/housekeeping/" >About this blog</a>
</li>
	<li class="cat-item cat-item-380"><a href="http://www.dbms2.com/category/analytic-glossary/" >Analytic glossary</a>
</li>
	<li class="cat-item cat-item-65"><a href="http://www.dbms2.com/category/analytics-technologies/" >Analytic technologies</a>
<ul class='children'>
	<li class="cat-item cat-item-66"><a href="http://www.dbms2.com/category/analytics-technologies/business-intelligence/" >Business intelligence</a>
</li>
	<li class="cat-item cat-item-102"><a href="http://www.dbms2.com/category/analytics-technologies/data-mart-warehouse-outsourcing/" >Data mart outsourcing</a>
</li>
	<li class="cat-item cat-item-13"><a href="http://www.dbms2.com/category/analytics-technologies/data-warehouse/" >Data warehousing</a>
</li>
	<li class="cat-item cat-item-14"><a href="http://www.dbms2.com/category/analytics-technologies/molap/" >MOLAP</a>
</li>
	<li class="cat-item cat-item-361"><a href="http://www.dbms2.com/category/analytics-technologies/predictive-modeling-advanced-analytics/" >Predictive modeling and advanced analytics</a>
</li>
</ul>
</li>
	<li class="cat-item cat-item-54"><a href="http://www.dbms2.com/category/applications/" >Application areas</a>
<ul class='children'>
	<li class="cat-item cat-item-55"><a href="http://www.dbms2.com/category/applications/games-virtual-worlds/" >Games and virtual worlds</a>
</li>
	<li class="cat-item cat-item-355"><a href="http://www.dbms2.com/category/applications/health-care-medical/" >Health care</a>
</li>
	<li class="cat-item cat-item-139"><a href="http://www.dbms2.com/category/applications/algorithmic-trading-investment-research/" >Investment research and trading</a>
</li>
	<li class="cat-item cat-item-326"><a href="http://www.dbms2.com/category/applications/log-file-logfile-analysis/" >Log analysis</a>
</li>
	<li class="cat-item cat-item-81"><a href="http://www.dbms2.com/category/applications/scientific-research/" >Scientific research</a>
</li>
	<li class="cat-item cat-item-110"><a href="http://www.dbms2.com/category/applications/telecommunications/" >Telecommunications</a>
</li>
	<li class="cat-item cat-item-254"><a href="http://www.dbms2.com/category/applications/web-analytics/" >Web analytics</a>
</li>
</ul>
</li>
	<li class="cat-item cat-item-290"><a href="http://www.dbms2.com/category/buying-processes/" >Buying processes</a>
<ul class='children'>
	<li class="cat-item cat-item-291"><a href="http://www.dbms2.com/category/buying-processes/benchmarks-and-pocs/" >Benchmarks and POCs</a>
</li>
</ul>
</li>
	<li class="cat-item cat-item-23"><a href="http://www.dbms2.com/category/products-and-vendors/" >Companies and products</a>
<ul class='children'>
	<li class="cat-item cat-item-99"><a href="http://www.dbms2.com/category/products-and-vendors/1010data/" >1010data</a>
</li>
	<li class="cat-item cat-item-70"><a href="http://www.dbms2.com/category/products-and-vendors/ab-initio-software-corporation/" >Ab Initio Software</a>
</li>
	<li class="cat-item cat-item-11"><a href="http://www.dbms2.com/category/products-and-vendors/ingres/" >Actian and Ingres</a>
</li>
	<li class="cat-item cat-item-360"><a href="http://www.dbms2.com/category/products-and-vendors/citrusleaf-aerospike/" >Aerospike</a>
</li>
	<li class="cat-item cat-item-332"><a href="http://www.dbms2.com/category/products-and-vendors/akiban/" >Akiban</a>
</li>
	<li class="cat-item cat-item-61"><a href="http://www.dbms2.com/category/products-and-vendors/coral8/" >Aleri and Coral8</a>
</li>
	<li class="cat-item cat-item-338"><a href="http://www.dbms2.com/category/products-and-vendors/algebraix/" >Algebraix</a>
</li>
	<li class="cat-item cat-item-67"><a href="http://www.dbms2.com/category/products-and-vendors/alpha-five/" >Alpha Five</a>
</li>
	<li class="cat-item cat-item-76"><a href="http://www.dbms2.com/category/products-and-vendors/amazon-simpledb-s3-ec2/" >Amazon and its cloud</a>
</li>
	<li class="cat-item cat-item-29"><a href="http://www.dbms2.com/category/products-and-vendors/ants/" >ANTs Software</a>
</li>
	<li class="cat-item cat-item-224"><a href="http://www.dbms2.com/category/products-and-vendors/aster-data-warehouse/" >Aster Data</a>
</li>
	<li class="cat-item cat-item-393"><a href="http://www.dbms2.com/category/products-and-vendors/ayasdi/" >Ayasdi</a>
</li>
	<li class="cat-item cat-item-349"><a href="http://www.dbms2.com/category/products-and-vendors/basho-riak/" >Basho and Riak</a>
</li>
	<li class="cat-item cat-item-33"><a href="http://www.dbms2.com/category/products-and-vendors/business-objects/" >Business Objects</a>
</li>
	<li class="cat-item cat-item-62"><a href="http://www.dbms2.com/category/products-and-vendors/calpont/" >Calpont</a>
</li>
	<li class="cat-item cat-item-331"><a href="http://www.dbms2.com/category/products-and-vendors/cassandra-products-and-vendors/" >Cassandra</a>
</li>
	<li class="cat-item cat-item-43"><a href="http://www.dbms2.com/category/products-and-vendors/cast-iron-systems/" >Cast Iron Systems</a>
</li>
	<li class="cat-item cat-item-382"><a href="http://www.dbms2.com/category/products-and-vendors/cirro/" >Cirro</a>
</li>
	<li class="cat-item cat-item-392"><a href="http://www.dbms2.com/category/products-and-vendors/citus-data-citusdb/" >Citus Data</a>
</li>
	<li class="cat-item cat-item-373"><a href="http://www.dbms2.com/category/products-and-vendors/clearstory-data/" >ClearStory Data</a>
</li>
	<li class="cat-item cat-item-376"><a href="http://www.dbms2.com/category/products-and-vendors/cloudant/" >Cloudant</a>
</li>
	<li class="cat-item cat-item-307"><a href="http://www.dbms2.com/category/products-and-vendors/cloudera/" >Cloudera</a>
</li>
	<li class="cat-item cat-item-337"><a href="http://www.dbms2.com/category/products-and-vendors/clustrix/" >Clustrix</a>
</li>
	<li class="cat-item cat-item-20"><a href="http://www.dbms2.com/category/products-and-vendors/7-degrees-cogito/" >Cogito and 7 Degrees</a>
</li>
	<li class="cat-item cat-item-28"><a href="http://www.dbms2.com/category/products-and-vendors/cognos-applix-tm1/" >Cognos</a>
</li>
	<li class="cat-item cat-item-321"><a href="http://www.dbms2.com/category/products-and-vendors/continuent-tungsten/" >Continuent</a>
</li>
	<li class="cat-item cat-item-335"><a href="http://www.dbms2.com/category/products-and-vendors/northscale-membase/" >Couchbase</a>
</li>
	<li class="cat-item cat-item-83"><a href="http://www.dbms2.com/category/products-and-vendors/couchdb/" >CouchDB</a>
</li>
	<li class="cat-item cat-item-383"><a href="http://www.dbms2.com/category/products-and-vendors/databricks-bdas-spark-shark-berkeley-amplab/" >Databricks, Spark and BDAS</a>
</li>
	<li class="cat-item cat-item-24"><a href="http://www.dbms2.com/category/products-and-vendors/datallegro/" >DATAllegro</a>
</li>
	<li class="cat-item cat-item-336"><a href="http://www.dbms2.com/category/products-and-vendors/datameer/" >Datameer</a>
</li>
	<li class="cat-item cat-item-340"><a href="http://www.dbms2.com/category/products-and-vendors/riptano/" >DataStax</a>
</li>
	<li class="cat-item cat-item-59"><a href="http://www.dbms2.com/category/products-and-vendors/dataupia/" >Dataupia</a>
</li>
	<li class="cat-item cat-item-341"><a href="http://www.dbms2.com/category/products-and-vendors/dbshards-code-futures/" >dbShards and CodeFutures</a>
</li>
	<li class="cat-item cat-item-85"><a href="http://www.dbms2.com/category/products-and-vendors/elastra/" >Elastra</a>
</li>
	<li class="cat-item cat-item-108"><a href="http://www.dbms2.com/category/products-and-vendors/emc/" >EMC</a>
</li>
	<li class="cat-item cat-item-363"><a href="http://www.dbms2.com/category/products-and-vendors/endeca/" >Endeca</a>
</li>
	<li class="cat-item cat-item-38"><a href="http://www.dbms2.com/category/products-and-vendors/enterprisedb-postgres-plus/" >EnterpriseDB and Postgres Plus</a>
</li>
	<li class="cat-item cat-item-89"><a href="http://www.dbms2.com/category/products-and-vendors/exasol/" >Exasol</a>
</li>
	<li class="cat-item cat-item-299"><a href="http://www.dbms2.com/category/products-and-vendors/expressor-software/" >Expressor</a>
</li>
	<li class="cat-item cat-item-50"><a href="http://www.dbms2.com/category/products-and-vendors/filemaker/" >FileMaker</a>
</li>
	<li class="cat-item cat-item-386"><a href="http://www.dbms2.com/category/products-and-vendors/geniedb/" >GenieDB</a>
</li>
	<li class="cat-item cat-item-330"><a href="http://www.dbms2.com/category/products-and-vendors/gooddata/" >Gooddata</a>
</li>
	<li class="cat-item cat-item-78"><a href="http://www.dbms2.com/category/products-and-vendors/google-mapreduce-bigtable/" >Google</a>
</li>
	<li class="cat-item cat-item-30"><a href="http://www.dbms2.com/category/products-and-vendors/greenplum/" >Greenplum</a>
</li>
	<li class="cat-item cat-item-318"><a href="http://www.dbms2.com/category/products-and-vendors/groovy-sql-switch/" >Groovy Corporation</a>
</li>
	<li class="cat-item cat-item-359"><a href="http://www.dbms2.com/category/products-and-vendors/hadapt/" >Hadapt</a>
</li>
	<li class="cat-item cat-item-306"><a href="http://www.dbms2.com/category/products-and-vendors/hadoop-products-and-vendors/" >Hadoop</a>
</li>
	<li class="cat-item cat-item-346"><a href="http://www.dbms2.com/category/products-and-vendors/hbase/" >HBase</a>
</li>
	<li class="cat-item cat-item-367"><a href="http://www.dbms2.com/category/products-and-vendors/hortonworks/" >Hortonworks</a>
</li>
	<li class="cat-item cat-item-47"><a href="http://www.dbms2.com/category/products-and-vendors/hp-and-neoview/" >HP and Neoview</a>
</li>
	<li class="cat-item cat-item-7"><a href="http://www.dbms2.com/category/products-and-vendors/ibm-and-db2/" >IBM and DB2</a>
	<ul class='children'>
	<li class="cat-item cat-item-270"><a href="http://www.dbms2.com/category/products-and-vendors/ibm-and-db2/purexml/" >pureXML</a>
</li>
	</ul>
</li>
	<li class="cat-item cat-item-92"><a href="http://www.dbms2.com/category/products-and-vendors/iluminate/" >illuminate Solutions</a>
</li>
	<li class="cat-item cat-item-68"><a href="http://www.dbms2.com/category/products-and-vendors/infobright-brighthouse/" >Infobright</a>
</li>
	<li class="cat-item cat-item-26"><a href="http://www.dbms2.com/category/products-and-vendors/informatica/" >Informatica</a>
</li>
	<li class="cat-item cat-item-303"><a href="http://www.dbms2.com/category/products-and-vendors/information-builders-ibi/" >Information Builders</a>
</li>
	<li class="cat-item cat-item-304"><a href="http://www.dbms2.com/category/products-and-vendors/inforsense/" >Inforsense</a>
</li>
	<li class="cat-item cat-item-27"><a href="http://www.dbms2.com/category/products-and-vendors/intel/" >Intel</a>
</li>
	<li class="cat-item cat-item-41"><a href="http://www.dbms2.com/category/products-and-vendors/intersystems-cache-ensemble/" >Intersystems and Cache&#039;</a>
</li>
	<li class="cat-item cat-item-245"><a href="http://www.dbms2.com/category/products-and-vendors/jaspersoft/" >Jaspersoft</a>
</li>
	<li class="cat-item cat-item-397"><a href="http://www.dbms2.com/category/products-and-vendors/confluent-kafka/" >Kafka and Confluent</a>
</li>
	<li class="cat-item cat-item-87"><a href="http://www.dbms2.com/category/products-and-vendors/kalido/" >Kalido</a>
</li>
	<li class="cat-item cat-item-357"><a href="http://www.dbms2.com/category/products-and-vendors/kaminario-k2/" >Kaminario</a>
</li>
	<li class="cat-item cat-item-93"><a href="http://www.dbms2.com/category/products-and-vendors/kickfire/" >Kickfire</a>
</li>
	<li class="cat-item cat-item-35"><a href="http://www.dbms2.com/category/products-and-vendors/kognitio/" >Kognitio</a>
</li>
	<li class="cat-item cat-item-372"><a href="http://www.dbms2.com/category/products-and-vendors/kxen/" >KXEN</a>
</li>
	<li class="cat-item cat-item-368"><a href="http://www.dbms2.com/category/products-and-vendors/mapr/" >MapR</a>
</li>
	<li class="cat-item cat-item-21"><a href="http://www.dbms2.com/category/products-and-vendors/marklogic/" >MarkLogic</a>
</li>
	<li class="cat-item cat-item-104"><a href="http://www.dbms2.com/category/products-and-vendors/mcobject-extremedb/" >McObject</a>
</li>
	<li class="cat-item cat-item-334"><a href="http://www.dbms2.com/category/products-and-vendors/memcached/" >memcached</a>
</li>
	<li class="cat-item cat-item-388"><a href="http://www.dbms2.com/category/products-and-vendors/memsql/" >MemSQL</a>
</li>
	<li class="cat-item cat-item-377"><a href="http://www.dbms2.com/category/products-and-vendors/metamarkets-druid/" >Metamarkets and Druid</a>
</li>
	<li class="cat-item cat-item-8"><a href="http://www.dbms2.com/category/products-and-vendors/microsoft-sqlserver/" >Microsoft and SQL*Server</a>
</li>
	<li class="cat-item cat-item-342"><a href="http://www.dbms2.com/category/products-and-vendors/microstrategy/" >MicroStrategy</a>
</li>
	<li class="cat-item cat-item-320"><a href="http://www.dbms2.com/category/products-and-vendors/monetdb/" >MonetDB</a>
</li>
	<li class="cat-item cat-item-347"><a href="http://www.dbms2.com/category/products-and-vendors/10gen-mongodb/" >MongoDB</a>
</li>
	<li class="cat-item cat-item-10"><a href="http://www.dbms2.com/category/products-and-vendors/mysql/" >MySQL</a>
</li>
	<li class="cat-item cat-item-378"><a href="http://www.dbms2.com/category/products-and-vendors/neo4j-neo-technology/" >Neo Technology and Neo4j</a>
</li>
	<li class="cat-item cat-item-32"><a href="http://www.dbms2.com/category/products-and-vendors/netezza/" >Netezza</a>
</li>
	<li class="cat-item cat-item-387"><a href="http://www.dbms2.com/category/products-and-vendors/nuodb/" >NuoDB</a>
</li>
	<li class="cat-item cat-item-394"><a href="http://www.dbms2.com/category/products-and-vendors/nutonian/" >Nutonian</a>
</li>
	<li class="cat-item cat-item-339"><a href="http://www.dbms2.com/category/products-and-vendors/objectivity-infinite-graph/" >Objectivity and Infinite Graph</a>
</li>
	<li class="cat-item cat-item-6"><a href="http://www.dbms2.com/category/products-and-vendors/oracle/" >Oracle</a>
	<ul class='children'>
	<li class="cat-item cat-item-267"><a href="http://www.dbms2.com/category/products-and-vendors/oracle/exadata-database-machine/" >Exadata</a>
</li>
	</ul>
</li>
	<li class="cat-item cat-item-58"><a href="http://www.dbms2.com/category/products-and-vendors/oracle-timesten/" >Oracle TimesTen</a>
</li>
	<li class="cat-item cat-item-69"><a href="http://www.dbms2.com/category/products-and-vendors/paraccel/" >ParAccel</a>
</li>
	<li class="cat-item cat-item-289"><a href="http://www.dbms2.com/category/products-and-vendors/pentaho/" >Pentaho</a>
</li>
	<li class="cat-item cat-item-44"><a href="http://www.dbms2.com/category/products-and-vendors/pervasive-software/" >Pervasive Software</a>
</li>
	<li class="cat-item cat-item-379"><a href="http://www.dbms2.com/category/products-and-vendors/pivotlink/" >PivotLink</a>
</li>
	<li class="cat-item cat-item-381"><a href="http://www.dbms2.com/category/products-and-vendors/platfora/" >Platfora</a>
</li>
	<li class="cat-item cat-item-31"><a href="http://www.dbms2.com/category/products-and-vendors/postgresql/" >PostgreSQL</a>
</li>
	<li class="cat-item cat-item-17"><a href="http://www.dbms2.com/category/products-and-vendors/progress-apama-datadirect/" >Progress, Apama, and DataDirect</a>
</li>
	<li class="cat-item cat-item-39"><a href="http://www.dbms2.com/category/products-and-vendors/qliktech-and-qlikview/" >QlikTech and QlikView</a>
</li>
	<li class="cat-item cat-item-282"><a href="http://www.dbms2.com/category/products-and-vendors/clearpace/" >Rainstor</a>
</li>
	<li class="cat-item cat-item-362"><a href="http://www.dbms2.com/category/products-and-vendors/revolution-analytics-r/" >Revolution Analytics</a>
</li>
	<li class="cat-item cat-item-395"><a href="http://www.dbms2.com/category/products-and-vendors/rocana-scalingdata/" >Rocana</a>
</li>
	<li class="cat-item cat-item-370"><a href="http://www.dbms2.com/category/products-and-vendors/salesforce-force-database-com-heroku/" >salesforce.com</a>
</li>
	<li class="cat-item cat-item-281"><a href="http://www.dbms2.com/category/products-and-vendors/sand-technology/" >SAND Technology</a>
</li>
	<li class="cat-item cat-item-18"><a href="http://www.dbms2.com/category/products-and-vendors/sap-bia-maxdb/" >SAP AG</a>
</li>
	<li class="cat-item cat-item-40"><a href="http://www.dbms2.com/category/products-and-vendors/sas-institute/" >SAS Institute</a>
</li>
	<li class="cat-item cat-item-358"><a href="http://www.dbms2.com/category/products-and-vendors/scalebase/" >ScaleBase</a>
</li>
	<li class="cat-item cat-item-94"><a href="http://www.dbms2.com/category/products-and-vendors/scaledb/" >ScaleDB</a>
</li>
	<li class="cat-item cat-item-348"><a href="http://www.dbms2.com/category/products-and-vendors/schooner-information-technology-appliance/" >Schooner Information Technology</a>
</li>
	<li class="cat-item cat-item-324"><a href="http://www.dbms2.com/category/products-and-vendors/scidb/" >SciDB</a>
</li>
	<li class="cat-item cat-item-327"><a href="http://www.dbms2.com/category/products-and-vendors/sensage/" >SenSage</a>
</li>
	<li class="cat-item cat-item-398"><a href="http://www.dbms2.com/category/products-and-vendors/sequoiadb-sequoiacm/" >SequoiaDB</a>
</li>
	<li class="cat-item cat-item-364"><a href="http://www.dbms2.com/category/products-and-vendors/snaplogic/" >SnapLogic</a>
</li>
	<li class="cat-item cat-item-74"><a href="http://www.dbms2.com/category/products-and-vendors/adabas-software-ag/" >Software AG</a>
</li>
	<li class="cat-item cat-item-25"><a href="http://www.dbms2.com/category/products-and-vendors/soliddb/" >solidDB</a>
</li>
	<li class="cat-item cat-item-328"><a href="http://www.dbms2.com/category/products-and-vendors/splunk/" >Splunk</a>
</li>
	<li class="cat-item cat-item-365"><a href="http://www.dbms2.com/category/products-and-vendors/starcounter/" >Starcounter</a>
</li>
	<li class="cat-item cat-item-36"><a href="http://www.dbms2.com/category/products-and-vendors/streambase/" >StreamBase</a>
</li>
	<li class="cat-item cat-item-42"><a href="http://www.dbms2.com/category/products-and-vendors/sybase/" >Sybase</a>
</li>
	<li class="cat-item cat-item-280"><a href="http://www.dbms2.com/category/products-and-vendors/syncsort/" >Syncsort</a>
</li>
	<li class="cat-item cat-item-305"><a href="http://www.dbms2.com/category/products-and-vendors/tableau-software/" >Tableau Software</a>
</li>
	<li class="cat-item cat-item-276"><a href="http://www.dbms2.com/category/products-and-vendors/talend/" >Talend</a>
</li>
	<li class="cat-item cat-item-34"><a href="http://www.dbms2.com/category/products-and-vendors/teradata/" >Teradata</a>
</li>
	<li class="cat-item cat-item-310"><a href="http://www.dbms2.com/category/products-and-vendors/tokutek-tokudb/" >Tokutek and TokuDB</a>
</li>
	<li class="cat-item cat-item-52"><a href="http://www.dbms2.com/category/products-and-vendors/truviso/" >Truviso</a>
</li>
	<li class="cat-item cat-item-319"><a href="http://www.dbms2.com/category/products-and-vendors/vectorwise/" >VectorWise</a>
</li>
	<li class="cat-item cat-item-37"><a href="http://www.dbms2.com/category/products-and-vendors/vertica-systems/" >Vertica Systems</a>
</li>
	<li class="cat-item cat-item-86"><a href="http://www.dbms2.com/category/products-and-vendors/h-store/" >VoltDB and H-Store</a>
</li>
	<li class="cat-item cat-item-371"><a href="http://www.dbms2.com/category/products-and-vendors/odiago-wibidata/" >WibiData</a>
</li>
	<li class="cat-item cat-item-345"><a href="http://www.dbms2.com/category/products-and-vendors/workday-inc/" >Workday</a>
</li>
	<li class="cat-item cat-item-323"><a href="http://www.dbms2.com/category/products-and-vendors/xkoto-gridscale/" >Xkoto</a>
</li>
	<li class="cat-item cat-item-317"><a href="http://www.dbms2.com/category/products-and-vendors/xtremedata-dbx/" >XtremeData</a>
</li>
	<li class="cat-item cat-item-375"><a href="http://www.dbms2.com/category/products-and-vendors/yarcdata-cray/" >Yarcdata and Cray</a>
</li>
	<li class="cat-item cat-item-366"><a href="http://www.dbms2.com/category/products-and-vendors/zettaset/" >Zettaset</a>
</li>
	<li class="cat-item cat-item-396"><a href="http://www.dbms2.com/category/products-and-vendors/zoomdata/" >Zoomdata</a>
</li>
</ul>
</li>
	<li class="cat-item cat-item-151"><a href="http://www.dbms2.com/category/data-integration-middleware/" >Data integration and middleware</a>
<ul class='children'>
	<li class="cat-item cat-item-152"><a href="http://www.dbms2.com/category/data-integration-middleware/application-servers/" >Application servers</a>
</li>
	<li class="cat-item cat-item-15"><a href="http://www.dbms2.com/category/data-integration-middleware/data-etl-etl-etlt-eai-eii/" >EAI, EII, ETL, ELT, ETLT</a>
</li>
</ul>
</li>
	<li class="cat-item cat-item-71"><a href="http://www.dbms2.com/category/datatype/" >Data types</a>
<ul class='children'>
	<li class="cat-item cat-item-72"><a href="http://www.dbms2.com/category/datatype/gis-geographic-geospatial/" >GIS and geospatial</a>
</li>
	<li class="cat-item cat-item-75"><a href="http://www.dbms2.com/category/datatype/object-oriented-database-management/" >Object</a>
</li>
	<li class="cat-item cat-item-56"><a href="http://www.dbms2.com/category/datatype/rdf-graph-database/" >RDF and graphs</a>
</li>
	<li class="cat-item cat-item-48"><a href="http://www.dbms2.com/category/datatype/native-xml-database/" >Structured documents</a>
</li>
	<li class="cat-item cat-item-73"><a href="http://www.dbms2.com/category/datatype/text-search/" >Text</a>
</li>
</ul>
</li>
	<li class="cat-item cat-item-124"><a href="http://www.dbms2.com/category/database-management-system/" >DBMS product categories</a>
<ul class='children'>
	<li class="cat-item cat-item-283"><a href="http://www.dbms2.com/category/database-management-system/archiving-and-information-preservation/" >Archiving and information preservation</a>
</li>
	<li class="cat-item cat-item-5"><a href="http://www.dbms2.com/category/database-management-system/data-warehouse-appliances/" >Data warehouse appliances</a>
</li>
	<li class="cat-item cat-item-77"><a href="http://www.dbms2.com/category/database-management-system/mid-range/" >Mid-range</a>
</li>
	<li class="cat-item cat-item-385"><a href="http://www.dbms2.com/category/database-management-system/newsql/" >NewSQL</a>
</li>
	<li class="cat-item cat-item-51"><a href="http://www.dbms2.com/category/database-management-system/online-transaction-processing-oltp/" >OLTP</a>
</li>
	<li class="cat-item cat-item-9"><a href="http://www.dbms2.com/category/database-management-system/open-source/" >Open source</a>
</li>
</ul>
</li>
	<li class="cat-item cat-item-60"><a href="http://www.dbms2.com/category/database-emulation-transparency-portability-compatibility/" >Emulation, transparency, portability</a>
</li>
	<li class="cat-item cat-item-250"><a href="http://www.dbms2.com/category/fun-stuff/" >Fun stuff</a>
<ul class='children'>
	<li class="cat-item cat-item-19"><a href="http://www.dbms2.com/category/fun-stuff/humor/" >Humor</a>
</li>
</ul>
</li>
	<li class="cat-item cat-item-227"><a href="http://www.dbms2.com/category/market-share/" >Market share and customer counts</a>
</li>
	<li class="cat-item cat-item-12"><a href="http://www.dbms2.com/category/memory-centric-data-management/" >Memory-centric data management</a>
<ul class='children'>
	<li class="cat-item cat-item-90"><a href="http://www.dbms2.com/category/memory-centric-data-management/cache/" >Cache</a>
</li>
	<li class="cat-item cat-item-156"><a href="http://www.dbms2.com/category/memory-centric-data-management/in-memory-dbms/" >In-memory DBMS</a>
</li>
	<li class="cat-item cat-item-57"><a href="http://www.dbms2.com/category/memory-centric-data-management/event-stream-processing/" >Streaming and complex event processing (CEP)</a>
</li>
</ul>
</li>
	<li class="cat-item cat-item-88"><a href="http://www.dbms2.com/category/michael-stonebraker/" >Michael Stonebraker</a>
</li>
	<li class="cat-item cat-item-225"><a href="http://www.dbms2.com/category/parallelization/" >Parallelization</a>
<ul class='children'>
	<li class="cat-item cat-item-322"><a href="http://www.dbms2.com/category/parallelization/database-clustering/" >Clustering</a>
</li>
	<li class="cat-item cat-item-226"><a href="http://www.dbms2.com/category/parallelization/mapreduce/" >MapReduce</a>
</li>
	<li class="cat-item cat-item-384"><a href="http://www.dbms2.com/category/parallelization/transparent-sharding/" >Transparent sharding</a>
</li>
</ul>
</li>
	<li class="cat-item cat-item-292"><a href="http://www.dbms2.com/category/presentations/" >Presentations</a>
</li>
	<li class="cat-item cat-item-111"><a href="http://www.dbms2.com/category/pricing/" >Pricing</a>
</li>
	<li class="cat-item cat-item-390"><a href="http://www.dbms2.com/category/technology-public-policy/" >Public policy</a>
<ul class='children'>
	<li class="cat-item cat-item-333"><a href="http://www.dbms2.com/category/technology-public-policy/privacy-surveillance-liberty/" >Surveillance and privacy</a>
</li>
</ul>
</li>
	<li class="cat-item cat-item-82"><a href="http://www.dbms2.com/category/software-as-a-service-database-saas/" >Software as a Service (SaaS)</a>
<ul class='children'>
	<li class="cat-item cat-item-84"><a href="http://www.dbms2.com/category/software-as-a-service-database-saas/cloud-computing/" >Cloud computing</a>
</li>
</ul>
</li>
	<li class="cat-item cat-item-80"><a href="http://www.dbms2.com/category/users/" >Specific users</a>
<ul class='children'>
	<li class="cat-item cat-item-91"><a href="http://www.dbms2.com/category/users/ebay/" >eBay</a>
</li>
	<li class="cat-item cat-item-190"><a href="http://www.dbms2.com/category/users/facebook-cassandra/" >Facebook</a>
</li>
	<li class="cat-item cat-item-302"><a href="http://www.dbms2.com/category/users/fox-interactive-media-myspace/" >Fox and MySpace</a>
</li>
	<li class="cat-item cat-item-354"><a href="http://www.dbms2.com/category/users/jpmorgan-chase/" >JPMorgan Chase</a>
</li>
	<li class="cat-item cat-item-100"><a href="http://www.dbms2.com/category/users/teoco/" >TEOCO</a>
</li>
	<li class="cat-item cat-item-138"><a href="http://www.dbms2.com/category/users/yahoo/" >Yahoo</a>
</li>
	<li class="cat-item cat-item-369"><a href="http://www.dbms2.com/category/users/zynga/" >Zynga</a>
</li>
</ul>
</li>
	<li class="cat-item cat-item-172"><a href="http://www.dbms2.com/category/storage/" >Storage</a>
<ul class='children'>
	<li class="cat-item cat-item-125"><a href="http://www.dbms2.com/category/storage/solid-state-memory-disk-flash/" >Solid-state memory</a>
</li>
</ul>
</li>
	<li class="cat-item cat-item-22"><a href="http://www.dbms2.com/category/database-theory-practice/" >Theory and architecture</a>
<ul class='children'>
	<li class="cat-item cat-item-64"><a href="http://www.dbms2.com/category/database-theory-practice/columnar-database-management/" >Columnar database management</a>
</li>
	<li class="cat-item cat-item-128"><a href="http://www.dbms2.com/category/database-theory-practice/data-models/" >Data models and architecture</a>
</li>
	<li class="cat-item cat-item-343"><a href="http://www.dbms2.com/category/database-theory-practice/data-pipelining/" >Data pipelining</a>
</li>
	<li class="cat-item cat-item-45"><a href="http://www.dbms2.com/category/database-theory-practice/database-compression/" >Database compression</a>
</li>
	<li class="cat-item cat-item-79"><a href="http://www.dbms2.com/category/database-theory-practice/database-diversity/" >Database diversity</a>
</li>
	<li class="cat-item cat-item-374"><a href="http://www.dbms2.com/category/database-theory-practice/derived-data/" >Derived data</a>
</li>
	<li class="cat-item cat-item-329"><a href="http://www.dbms2.com/category/database-theory-practice/nosql/" >NoSQL</a>
</li>
	<li class="cat-item cat-item-315"><a href="http://www.dbms2.com/category/database-theory-practice/petabyte-database-theory-practice/" >Petabyte-scale data management</a>
</li>
	<li class="cat-item cat-item-389"><a href="http://www.dbms2.com/category/database-theory-practice/schema-on-need/" >Schema on need</a>
</li>
	<li class="cat-item cat-item-391"><a href="http://www.dbms2.com/category/database-theory-practice/sqlhadoop-integration/" >SQL/Hadoop integration</a>
</li>
	<li class="cat-item cat-item-344"><a href="http://www.dbms2.com/category/database-theory-practice/workload-management/" >Workload management</a>
</li>
</ul>
</li>
	<li class="cat-item cat-item-16"><a href="http://www.dbms2.com/category/transrelational/" >TransRelational</a>
</li>
	<li class="cat-item cat-item-1"><a href="http://www.dbms2.com/category/uncategorized/" >Uncategorized</a>
</li>
		</ul>
	</li>
		
	<li id="Archives">
	<h2>Date archives</h2> <!-- archives are displayed in a dropdown to save room -->
		<ul>
			<select name="archive-dropdown" onChange='document.location.href=this.options[this.selectedIndex].value;'>
			<option value="">Select Month</option>
				<option value='http://www.dbms2.com/2018/06/'> June 2018 </option>
	<option value='http://www.dbms2.com/2018/05/'> May 2018 </option>
	<option value='http://www.dbms2.com/2018/02/'> February 2018 </option>
	<option value='http://www.dbms2.com/2018/01/'> January 2018 </option>
	<option value='http://www.dbms2.com/2017/12/'> December 2017 </option>
	<option value='http://www.dbms2.com/2017/08/'> August 2017 </option>
	<option value='http://www.dbms2.com/2017/06/'> June 2017 </option>
	<option value='http://www.dbms2.com/2017/04/'> April 2017 </option>
	<option value='http://www.dbms2.com/2017/03/'> March 2017 </option>
	<option value='http://www.dbms2.com/2017/02/'> February 2017 </option>
	<option value='http://www.dbms2.com/2016/12/'> December 2016 </option>
	<option value='http://www.dbms2.com/2016/11/'> November 2016 </option>
	<option value='http://www.dbms2.com/2016/10/'> October 2016 </option>
	<option value='http://www.dbms2.com/2016/09/'> September 2016 </option>
	<option value='http://www.dbms2.com/2016/08/'> August 2016 </option>
	<option value='http://www.dbms2.com/2016/07/'> July 2016 </option>
	<option value='http://www.dbms2.com/2016/06/'> June 2016 </option>
	<option value='http://www.dbms2.com/2016/05/'> May 2016 </option>
	<option value='http://www.dbms2.com/2016/02/'> February 2016 </option>
	<option value='http://www.dbms2.com/2016/01/'> January 2016 </option>
	<option value='http://www.dbms2.com/2015/12/'> December 2015 </option>
	<option value='http://www.dbms2.com/2015/11/'> November 2015 </option>
	<option value='http://www.dbms2.com/2015/10/'> October 2015 </option>
	<option value='http://www.dbms2.com/2015/09/'> September 2015 </option>
	<option value='http://www.dbms2.com/2015/08/'> August 2015 </option>
	<option value='http://www.dbms2.com/2015/07/'> July 2015 </option>
	<option value='http://www.dbms2.com/2015/06/'> June 2015 </option>
	<option value='http://www.dbms2.com/2015/05/'> May 2015 </option>
	<option value='http://www.dbms2.com/2015/04/'> April 2015 </option>
	<option value='http://www.dbms2.com/2015/03/'> March 2015 </option>
	<option value='http://www.dbms2.com/2015/02/'> February 2015 </option>
	<option value='http://www.dbms2.com/2015/01/'> January 2015 </option>
	<option value='http://www.dbms2.com/2014/12/'> December 2014 </option>
	<option value='http://www.dbms2.com/2014/11/'> November 2014 </option>
	<option value='http://www.dbms2.com/2014/10/'> October 2014 </option>
	<option value='http://www.dbms2.com/2014/09/'> September 2014 </option>
	<option value='http://www.dbms2.com/2014/08/'> August 2014 </option>
	<option value='http://www.dbms2.com/2014/07/'> July 2014 </option>
	<option value='http://www.dbms2.com/2014/06/'> June 2014 </option>
	<option value='http://www.dbms2.com/2014/05/'> May 2014 </option>
	<option value='http://www.dbms2.com/2014/04/'> April 2014 </option>
	<option value='http://www.dbms2.com/2014/03/'> March 2014 </option>
	<option value='http://www.dbms2.com/2014/02/'> February 2014 </option>
	<option value='http://www.dbms2.com/2014/01/'> January 2014 </option>
	<option value='http://www.dbms2.com/2013/12/'> December 2013 </option>
	<option value='http://www.dbms2.com/2013/11/'> November 2013 </option>
	<option value='http://www.dbms2.com/2013/10/'> October 2013 </option>
	<option value='http://www.dbms2.com/2013/09/'> September 2013 </option>
	<option value='http://www.dbms2.com/2013/08/'> August 2013 </option>
	<option value='http://www.dbms2.com/2013/07/'> July 2013 </option>
	<option value='http://www.dbms2.com/2013/06/'> June 2013 </option>
	<option value='http://www.dbms2.com/2013/05/'> May 2013 </option>
	<option value='http://www.dbms2.com/2013/04/'> April 2013 </option>
	<option value='http://www.dbms2.com/2013/03/'> March 2013 </option>
	<option value='http://www.dbms2.com/2013/02/'> February 2013 </option>
	<option value='http://www.dbms2.com/2013/01/'> January 2013 </option>
	<option value='http://www.dbms2.com/2012/12/'> December 2012 </option>
	<option value='http://www.dbms2.com/2012/11/'> November 2012 </option>
	<option value='http://www.dbms2.com/2012/10/'> October 2012 </option>
	<option value='http://www.dbms2.com/2012/09/'> September 2012 </option>
	<option value='http://www.dbms2.com/2012/08/'> August 2012 </option>
	<option value='http://www.dbms2.com/2012/07/'> July 2012 </option>
	<option value='http://www.dbms2.com/2012/06/'> June 2012 </option>
	<option value='http://www.dbms2.com/2012/05/'> May 2012 </option>
	<option value='http://www.dbms2.com/2012/04/'> April 2012 </option>
	<option value='http://www.dbms2.com/2012/03/'> March 2012 </option>
	<option value='http://www.dbms2.com/2012/02/'> February 2012 </option>
	<option value='http://www.dbms2.com/2012/01/'> January 2012 </option>
	<option value='http://www.dbms2.com/2011/11/'> November 2011 </option>
	<option value='http://www.dbms2.com/2011/10/'> October 2011 </option>
	<option value='http://www.dbms2.com/2011/09/'> September 2011 </option>
	<option value='http://www.dbms2.com/2011/08/'> August 2011 </option>
	<option value='http://www.dbms2.com/2011/07/'> July 2011 </option>
	<option value='http://www.dbms2.com/2011/06/'> June 2011 </option>
	<option value='http://www.dbms2.com/2011/05/'> May 2011 </option>
	<option value='http://www.dbms2.com/2011/04/'> April 2011 </option>
	<option value='http://www.dbms2.com/2011/03/'> March 2011 </option>
	<option value='http://www.dbms2.com/2011/02/'> February 2011 </option>
	<option value='http://www.dbms2.com/2011/01/'> January 2011 </option>
	<option value='http://www.dbms2.com/2010/12/'> December 2010 </option>
	<option value='http://www.dbms2.com/2010/11/'> November 2010 </option>
	<option value='http://www.dbms2.com/2010/10/'> October 2010 </option>
	<option value='http://www.dbms2.com/2010/09/'> September 2010 </option>
	<option value='http://www.dbms2.com/2010/08/'> August 2010 </option>
	<option value='http://www.dbms2.com/2010/07/'> July 2010 </option>
	<option value='http://www.dbms2.com/2010/06/'> June 2010 </option>
	<option value='http://www.dbms2.com/2010/05/'> May 2010 </option>
	<option value='http://www.dbms2.com/2010/04/'> April 2010 </option>
	<option value='http://www.dbms2.com/2010/03/'> March 2010 </option>
	<option value='http://www.dbms2.com/2010/02/'> February 2010 </option>
	<option value='http://www.dbms2.com/2010/01/'> January 2010 </option>
	<option value='http://www.dbms2.com/2009/12/'> December 2009 </option>
	<option value='http://www.dbms2.com/2009/11/'> November 2009 </option>
	<option value='http://www.dbms2.com/2009/10/'> October 2009 </option>
	<option value='http://www.dbms2.com/2009/09/'> September 2009 </option>
	<option value='http://www.dbms2.com/2009/08/'> August 2009 </option>
	<option value='http://www.dbms2.com/2009/07/'> July 2009 </option>
	<option value='http://www.dbms2.com/2009/06/'> June 2009 </option>
	<option value='http://www.dbms2.com/2009/05/'> May 2009 </option>
	<option value='http://www.dbms2.com/2009/04/'> April 2009 </option>
	<option value='http://www.dbms2.com/2009/03/'> March 2009 </option>
	<option value='http://www.dbms2.com/2009/02/'> February 2009 </option>
	<option value='http://www.dbms2.com/2009/01/'> January 2009 </option>
	<option value='http://www.dbms2.com/2008/12/'> December 2008 </option>
	<option value='http://www.dbms2.com/2008/11/'> November 2008 </option>
	<option value='http://www.dbms2.com/2008/10/'> October 2008 </option>
	<option value='http://www.dbms2.com/2008/09/'> September 2008 </option>
	<option value='http://www.dbms2.com/2008/08/'> August 2008 </option>
	<option value='http://www.dbms2.com/2008/07/'> July 2008 </option>
	<option value='http://www.dbms2.com/2008/06/'> June 2008 </option>
	<option value='http://www.dbms2.com/2008/05/'> May 2008 </option>
	<option value='http://www.dbms2.com/2008/04/'> April 2008 </option>
	<option value='http://www.dbms2.com/2008/03/'> March 2008 </option>
	<option value='http://www.dbms2.com/2008/02/'> February 2008 </option>
	<option value='http://www.dbms2.com/2008/01/'> January 2008 </option>
	<option value='http://www.dbms2.com/2007/12/'> December 2007 </option>
	<option value='http://www.dbms2.com/2007/11/'> November 2007 </option>
	<option value='http://www.dbms2.com/2007/10/'> October 2007 </option>
	<option value='http://www.dbms2.com/2007/09/'> September 2007 </option>
	<option value='http://www.dbms2.com/2007/08/'> August 2007 </option>
	<option value='http://www.dbms2.com/2007/07/'> July 2007 </option>
	<option value='http://www.dbms2.com/2007/06/'> June 2007 </option>
	<option value='http://www.dbms2.com/2007/05/'> May 2007 </option>
	<option value='http://www.dbms2.com/2007/04/'> April 2007 </option>
	<option value='http://www.dbms2.com/2007/03/'> March 2007 </option>
	<option value='http://www.dbms2.com/2007/02/'> February 2007 </option>
	<option value='http://www.dbms2.com/2007/01/'> January 2007 </option>
	<option value='http://www.dbms2.com/2006/12/'> December 2006 </option>
	<option value='http://www.dbms2.com/2006/11/'> November 2006 </option>
	<option value='http://www.dbms2.com/2006/10/'> October 2006 </option>
	<option value='http://www.dbms2.com/2006/09/'> September 2006 </option>
	<option value='http://www.dbms2.com/2006/08/'> August 2006 </option>
	<option value='http://www.dbms2.com/2006/07/'> July 2006 </option>
	<option value='http://www.dbms2.com/2006/06/'> June 2006 </option>
	<option value='http://www.dbms2.com/2006/05/'> May 2006 </option>
	<option value='http://www.dbms2.com/2006/04/'> April 2006 </option>
	<option value='http://www.dbms2.com/2006/03/'> March 2006 </option>
	<option value='http://www.dbms2.com/2006/02/'> February 2006 </option>
	<option value='http://www.dbms2.com/2006/01/'> January 2006 </option>
	<option value='http://www.dbms2.com/2005/12/'> December 2005 </option>
	<option value='http://www.dbms2.com/2005/11/'> November 2005 </option>
	<option value='http://www.dbms2.com/2005/10/'> October 2005 </option>
	<option value='http://www.dbms2.com/2005/09/'> September 2005 </option>
	<option value='http://www.dbms2.com/2005/08/'> August 2005 </option>
 </select>
		</ul>
	</li>

		</ul>


</div>



<!-- end l_sidebar --> <!-- on the left, where categories, etc. are listed -->

<!-- begin r_sidebar -->

<div id="r_sidebar">

	<ul id="r_sidebarwidgeted">
		
  
	<li id="Links">
	<p class="h2-nospace">Links</p>
		<ul>
			<li><a href="http://www.monash.com">Monash Research</a></li>
<li><a href="http://www.monash.com/whitepapers.html">White Papers</a></li>
		</ul>
	</li>
	
	<li>
<h2>Admin</h2>
<ul>
		<li><a href="http://www.dbms2.com/wp-login.php">Log in</a></li>
	</ul>
</li>
		
		</ul>

		
</div>

<!-- end r_sidebar --> <!-- on the lower right, below static sidebar; where links and admin are listed -->

</div>

<!-- The main column ends  -->

<!-- begin footer -->

<div style="clear:both;"></div>

<div id="footer">
<div id="inline-list" align="center">	
   		<ul>

			<li><a href="http://www.dbms2.com">Home</a></li>

			<li><a href="http://www.dbms2.com/database-blog/">About</a></li>
			
			<li><a href="http://www.monash.com/contact.html">Contact</a></li>

			<li><a href="http://www.monash.com/signup.html">Feeds</a></li>

		</ul>
</div>
  <p>Copyright &copy; <a href="http://www.monash.com">Monash Research</a>, 2005-2008.&nbsp;&nbsp; 
    Theme designed by <a href="http://www.melissabradshaw.com">Melissa Bradshaw</a>. 
    &nbsp;&nbsp;&nbsp; 
        <script type='text/javascript' src='http://www.dbms2.com/wp-includes/js/wp-embed.min.js?ver=4.9.6'></script>
<script async="async" type='text/javascript' src='http://www.dbms2.com/wp-content/plugins/akismet/_inc/form.js?ver=4.0.8'></script>
</div>
</body>
</html>